Manage - Additional Attributes Not Saving on Products (except Hearing Aids)
Issue
Additional attributes are not being saved when added to products, except for Hearing Aids. This prevents correct SKU configuration from being completed.
Cause
The issue is caused by a missing step during attribute setup.
When adding an Additional Attribute for Orders, selecting the attribute name (e.g. “Tube Size”) is only the first step. The attribute must also have a value selected before it can be saved.
Resolution
To correctly add and save an Additional Attribute:
Go to Environment Settings > Inventory Settings > Additional Attributes for Orders
Define the attribute name (e.g. “Tube Size”) and its available values (e.g. 1, 2, 3, 4, 5)
When adding a product (e.g. under “RIC Receivers”), select the attribute from the dropdown
After the attribute field appears, click into it again and select one or more values
Save the product
Expected behaviour
The attribute will only be saved if at least one value is selected
If no value is selected, the attribute will not persist after saving
This applies to all product types, not only Hearing Aids
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